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1. Q-Str2-Models Description: 

Q-Str2-Models is a complementary software or plugin for QGIS developed under the "PyQGIS" 

API of the Python language, it is published under the free software license GPL (General Public 

License) and multiplatform, it allows us to obtain in a semi-automated way the values resulting 

from the maximum geodetic deformation, shear deformation, rotation and dilatation in 

geodynamically active areas, from the horizontal velocities (East, North) of a series of GNSS 

stations (points), also allows us to create Stress-Strain tensors from of a regular grid. 

2. Hardware & Software Requirements: 

The minimum hardware required is a computer with a dual core processor, 2GB Memory RAM, 

3GB of free hard disk space, software required is QGIS 3.22 or later LTR version, the main 

programming language used for development was Python3 With PyQGIS API, program size is 

350KB approximately and source code from: https://lagc.uca.es/servicios-

homologados/software/ (official website of the Astronomy, Geodesy and Cartography 

Laboratory) & https://github.com/lagc-uca/Q-Str2-Models (Official GitHub Repository of the 

LAGC--UCA). The operating system it the plugin “Q-Str2-Models” was tested is “Ubuntu 22.04 

LTS” (64-bits).  

3. Installation Instructions: 

Initially, the Python3 libraries required to run the application are; Basemap, Numpy and Scipy. 

The commands to execute from the Linux console for its installation are: 

sudo apt-get install pip 

pip3 install basemap 

sudo apt-get install python3-numpy python3-scipy 

sudo apt install python3-mpltoolkits.basemap 

 

 

 

 

 

 

 

  

https://lagc.uca.es/servicios-homologados/software/
https://lagc.uca.es/servicios-homologados/software/
https://github.com/lagc-uca/Q-Str2-Models
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Later we download and install the corresponding version of QGIS 3 LTR 

(https://www.qgis.org/es/site/forusers/alldownloads.html#debian-ubuntu), the minimum 

required version of QGIS is 3.16 LTR. 

3.1 Download the application: 

The next step is to download the Strain_Stress_App.zip file from the followings webpages:  

https://lagc.uca.es/servicios-homologados/software/  

https://github.com/lagc-uca/Q-Str2-Models (mirror 2) 

Next we will install the Strain_Stress_App.zip file in QGIS:  

3.2 Install the application: 

Plugins → Manage and Install plugins → Install from ZIP → Install Plugin. Do not unzipped the 

Strain_Stress_App.zip file as QGIS required an .zip file to install a new application.  

 

  

 

 

 

  

 

 

Then Verify the app is well installed:  

Plugins → Manage and Install plugins → Installed →  Q-Str2-Models “checked”. If needed, please 

restart QGIS software.  

 

 

 

 

 

 

  

https://www.qgis.org/es/site/forusers/alldownloads.html#debian-ubuntu
https://lagc.uca.es/servicios-homologados/software/
https://github.com/lagc-uca/Q-Str2-Models
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3.3 Running the application: 

Later we will run the application by selecting the new icon (blue grid)       found in the top 

toolbar of QGIS. 

 

 

 

 

 

 

 

 

 

 

4. Input & Output Data 

For the “Q-Str2-Models” application to work correctly, we must initially have a QGIS layer 

(shapefile) with the points to analyze. (Previously to create a shapefile from a text file we can 

use the QGIS tool: Layer → Add Layer → Add Delimited Text Layer). 
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Once the shapefile was created,add into the Qgis layers box, located on the side of Qgis (main 

environment). This file only contains the points to be analyzed (coordinates in latitude and 

longitude). Initially in this example, the input objects contain a coordinate reference system 

(CRS) of type "EPSG: 3857”. 

An optimal CRS should be used for the different possible scenarios. As we mentioned in the 

article associated with this application, for the testing of this software we used 65 GNSS stations 

from the SPINA region (South of the Iberian Peninsula and North Africa). 

 

 

 

 

 

 

 

 

 

The second required input file is a “CSV” or simple text file containing the same coordinates of 

the stations to be analyzed with the horizontal velocities (East, North) of the same points, these 

velocities are essential to know the objective parameters of the developed software (maximum 

geodetic deformation, shear deformation, dilatation, rotation, and Strain-Stress tensors 

parameters). This CSV file is added by selecting the "Input Data File" option located at the 

beginning of the Q-Str2-Models processing module. 
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Later we will select the "Save Data File" option, which will open a destination folder selection 

window on our local disk, where the file (CSV) with the results will be saved (maximum geodetic 

deformation, shear deformation, dilatation, rotation, and Strain-Stress tensors parameters), 

remember to name this file. 

 

In this step, we already have the input data file and output path required to apply the following 

application options. On the right side of the application, we can see a display box with the 

content (horizontal velocities) of the input data file (CSV) introduced initially. 

 

 

 

 

 

 

 

 

 

 

 

  



7 

 

5. Selection Interpolation Method 

As we have defined in the associated article, to obtain the results we must first apply an 

interpolation method to the data under study, this application offers us the following: IDW, 

Delaunay, Exponential and Around. For this example, we will use the IDW method since it is the 

most optimal in our study scenario (SPINA Region). The selection of the most optimal method 

often depends on the number of GNSS stations used and the quality of their data. 

 

 

 

 

 

 

 

 

 

 

We will also select the active layer (into QGIS layer box) to which we will apply the selected 

interpolation method. Remember that we added this active layer to QGIS in the first few steps. 
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6. Select Frame & Create Grid Options 

Continuing with the options that Q-Str2-Models provides us, we will find the "Customize Grid" 

section in which we will indicate the number of rows and columns required for the creation of a 

temporary grid used by the interpolation method selected, and the CRS to use. The "Select 

Frame" button allows us (by clicking on the points and dragging the mouse) to create a study 

area where the custom grid will be located. With the "Create Grid" button, we execute the 

options described above. Remember that the results will be saved in the destination folder (on 

the local disk) previously selected. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Once the grid (15 x 15 in this case) has been created in our area of interest and the final results 

have been generated (???_????_IDW.csv), we will import it into the QGIS layer box to use the 

options of the next module (Graphics Module) of the application. Below we show the generated 

results. 
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7. Create Vectors & Stress-Strain Tensors Options 

The graphics module is divided into two sub-modules: Stress-Strain options and Raster options, 

in the first we can graph horizontal displacement vectors of the points by clicking the "Create 

vectors" button (see letter d, of the section “Helpful tips for using the app”) as well as the Stress-

Strain tensors by clicking the button "Create tensors" in the active layer that we want to analyze.  

Remember that this active layer must contain the horizontal velocities to create the 

corresponding vectors and Stress-Strain tensors. In this case, we will create the vectors and/or 

Stress-Strain tensors, on the active layer (results mentioned in the previous step) of the layers 

box of the main QGIS environment. Further customizations and creation of legends or scale bars 

will be done with the QGIS "Create Print Layout" tool. 
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8. Create Rasters Options 

In the second graphic submodule (Raster Options) we initially have a "Select element to draw" 

combo box that allows us to select one of the four available options (Maximum Geodesic 

Deformation "MAXGEO", Rotation, Dilation and Shear Deformation "SHEAR"), later we have a 

button that allows us to save our raster image (.tiff format) in a folder on the local disk. When 

executing the "Create Raster" button, the QGIS process will start, which will last approximately 

10 seconds (this depends on the performance of the hardware used, the number of points to 

study and the number of points assigned to the grid), then this raster will be automatically 

imported into the layers box of the QGIS environment.  

Before doing "Create Raster" it is recommended to have only the layer with the results active 

(QGIS environment layers box) to avoid conflicts with the project's CRS and/or other QGIS 

objects. 

 

 

 

 

 

 

  

 

 

The subsequent customization of the raster images (styles, colors, transparency, etc.) will 

depend on the preference of the user and the correct edition of the properties of the raster 

layer created. 
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9. “Q-Str2-Models” Windows Installation 

For a correct installation of the "Q-Str2-Models" application in QGIS under the Windows 

platform (Windows 10 Pro 22H2 was used in this section), we must initially make sure that QGIS 

has the Python "basemap" library installed, for this, run the QGIS shell or terminal called; 

"OSGeo4W Shell", this tool will be added automatically when we install an LTR version of QGIS. 

We must make sure that we have the corresponding user permissions to run this application. 

When we execute the "OSGeo4W Shell" we must insert the command: pip install basemap so 

that the package manager can verify and/or install the indicated library (remember to have an 

internet connection before carrying out this step), at the end, this manager will show us a 

message with the description of the installation. You can optionally install other major python 

libraries (numpy, scipy, etc) or upgrade the pip package manager using the command: 

 pip install --upgrade pip 

 

 

 

 

 

 

 

 

 

If the previous steps were executed successfully, you can continue installing the "Q-Str2-

Models" plugin in section 3.1 (Download the application) of this guide, otherwise, it is very likely 

that QGIS will show the following error when starting: 
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10. Helpful tips for using the app 

 
a. If we are using the "Q-Str2-Models" application under Windows O.S, make sure that the 

working directory (where the input-output data and shapefiles are located) are not in a 

complex path, avoid folder names with special characters and letters accentuated. It is 

recommended to use a simple path e.g., “C:\Data_Test” 

 
b. Make sure that the input file containing the velocities and coordinates to be analyzed is 

in "CSV" format, has a simple header and that the columns are separated by commas. 

 
c. The most appropriate way to use the application is to select the options in the indicated 

order: 

1) Insert the layer of points to be analyzed in the "Qgis Layer Box".  

2) Insert Input data file (CSV file).  

3) Press "Save data file" in a simple output path.  

4) Press "Select Interpolation method".  

5) Press "Select active layer". 

6) Select customize Grid (10x10 default).  

7) Press “Select frame” and then create a zone of interest in the imported points 

(holding the left mouse click on the points to create a box).  

8) Go back to the application and press the “Create Grid” option to create the 

regular grid of points.  

9) Go to the graphic module and create the Stress-Strain tensors with the “Create 

Tensors” option.  

10) Then we select the item to draw, we look for a path to save the image and we 

create the raster with the "Create Raster" option; this will take less than 10 

seconds and will depend on the matrix defined for the mesh and the size of the 

area interest defined in previous steps. 

 
d. The "Create Vectors" option is applied to the imported points (shapefile) to the "Qgis 

Layer Box" that contain only geographic coordinates and horizontal velocities, in this 

case, you should avoid performing the steps of point c. We only need press the "Create 

Vectors” option. 

 

e. If when using the "Create Tensors" option tensors with exaggerated scales are created, 

we must review the coordinate reference system of our QGIS, the resulting values and 

arrow scales in the symbology properties of the newly created layer. 


